欢迎来到王星个人博客!seo教程,DEDECMS织梦免费模板

王星个人博客

MariaDB

当前位置:主页 > 数据库 > MariaDB >

关于MariaDB安装问题小记(CMake Error at)

时间:2017-11-22|栏目:MariaDB|点击:

文章摘要:今日在安装MariaDB的时候始终提示如下错误,但是我已经安装了libaio-devel库: CMake Error at cmake/build_configurations/mysql_release.cmake:128 (MESSAGE): aio is required on Linux, you need to install the required lib

今日在安装MariaDB的时候始终提示如下错误,但是我已经安装了libaio-devel库:
  CMake Error at cmake/build_configurations/mysql_release.cmake:128 (MESSAGE):
  aio is required on Linux, you need to install the required library:
  Debian/Ubuntu: apt-get install libaio-dev
  RedHat/Fedora/Oracle Linux: yum install libaio-devel
  SuSE: zypper install libaio-devel
  If you really do not want it, pass -DIGNORE_AIO_CHECK to cmake.
搜寻各种解决方案后才知道因为刚开始第一次执行cmake的时候就产生了CMakeCache.txt,这个时候我并没有安装libaio-devel库,然后继续安装依赖库后再执行cmake其实读取的依然是前面生成的cache文件,导致cmake判断libaio-devel一直未被安装。
因此只要我们rm删除CMakeCache.txt文件后重新执行cmake命令既可以解决此问题

上一篇:没有了

栏    目:MariaDB

下一篇:从MySQL 5.5迁移到Mariadb 10.1.14所遇到的问题

本文标题:关于MariaDB安装问题小记(CMake Error at)

本文地址:http://www.aiquhu.com/shujuku/Mariadb/50.html

广告投放 | 联系我们 | 版权申明 | 网站地图(html) | 网站地图(xml)

重要申明:本站所有的文章、图片、评论等,均由网友发表或上传并维护或收集自网络,属个人行为,与本站立场无关。

如果侵犯了您的权利,请与我们联系,我们将在24小时内进行处理、任何非本站因素导致的法律后果,本站均不负任何责任。

联系QQ:520031800 | 邮箱:520031800@qq.com

Copyright ©2019-2020 王星个人博客 版权所有 苏ICP备18070909号